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1 Introduction 

The TFP3 (The Flash Programmer 3) is a multipurpose device from Maxim Integrated used to perform flash 
program and erase operations on Maxim energy metering SoCs. The available versions of the TFP3 are 
listed in Table 1. 

Table 1: TFP3 Versions 

ID Function Ordering Part Number 

TFP3-8051 Flash Programmer for 8051-based Metering 
Devices. With Security (1) 

80515-FPBM-TFP3 

TFP3L-MAXQ30 Flash Programmer for ZON™ Family Metering 
Devices (MAXQ®-based).  No Security 

MAXQ30-FPBM-TFP3L# 

TFP3Q-MAXQ30 Flash Programmer for ZON™ Family Metering 
Devices (MAXQ-based).  With Security (1) 

MAXQ30-FPBM-TFP3Q# 

(1) With the security feature, the programming content is stored, programmed, and verified using AES 
128-bit security. 

2 TFP3 Kit Contents 

● TFP3 Device  

● FC-10 cable for CC51 or JTAG connection, 20-25cm in length 

● USB A-to-B cable used to connect the TFP3 to the host (PC) or to a USB 5V DC adapter (not provided 
with the kit) 

● CD-ROM containing: 

o TFP3 Windows installation executable (TFP3 XX-YY.exe) with Microsoft .NET 4.0 packaged for 
TFP3 GUI and CLI application software 

o TFP3 Host USB CDC driver 

o TFP3 User’s Guide 

o TFP3 Quick Start Guide  

MAXQ is a registered trademark and ZON is a trademark of Maxim Integrated Products, Inc. 
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3 Setup and Operations 

Figure 1 shows the basic connection diagrams for the TFP3 for programming ZON (MAXQ30-based) and 
71M65xx (8051-based) parts. It is possible to operate the TFP3 in both stand-alone (only target and TFP3) 
and PC-connected configurations. For stand-alone configurations, the TFP3 must be powered through the 
USB adaptor. 

The ZON SOC or 71M65xx SOC is referred to as the target or DUT (device under test). The TFP3 contains 
the target image, i.e. the operational code for the flash memory of the target, in encrypted form (TFP3Q-
MAXQ30 and TFP3-8051) or unencrypted form (TFP3L-MAXQ30).  

 

TFP3

USB Cable ATE

ICE

MAXQ-Based 
Device

Stand-Alone 
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TFP3

USB Cable 8051-Based
Device

Stand-Alone 
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ATE

ICE
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Figure 1: TFP3 Typical Connection Diagram 
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3.1 TFP3 Connection to the Host 
Connect the USB A-B cable to the TFP3 (Host/Power Port) as shown in Figure 2. Plug the other end of the 
USB cable into an available USB port of a PC. 

 

Figure 2: TFP3 Connection to Host 

When the notification window with the text, "Installing device driver software," appears on the PC screen, 
go to Start > Control Panel > Device Manager > Other Devices.  Right-click on "MAXQ CDC-ACM Demo," 
and then update the driver software by pointing to the "OEM54.INF" file on the CD-ROM supplied with 
the TFP3 Programmer’s Kit. 

 

Figure 3: Device Manager 
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When the TFP3 Host driver software installation is successful, the TFP3 device is enumerated as a COM 
port, as shown in Figure 4. 

 

Figure 4: COM Port Enumeration 

3.2 TFP3 Software GUI Installation 
Insert the CD-ROM supplied with the TFP3 Kit into your PC and browse to the TFP3 Host software 
directory. Double-click the file named "TFP3 - XX.YY.exe" to start the installation process ("XX" and "YY" 
are major and minor versions, respectively).  Follow the on-screen instructions carefully to successfully 
complete the TFP3 host software installation. 

3.3 TFP3 Connection to Target 
The 2x5 connector labeled “ICE” is intended for the target cable. Table 2 shows the signal assignment on 
this connector.  Pin 1 is in the top right position when looking at the connector from the outside, and pin 2 
is on the bottom-right. 

Pin 1
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3.3.1 TFP3 Connected to ZON Device (TFP3Q-MAXQ30 and TFP3L-MAXQ30) 
Plug the gray flat-ribbon cable into the 2x5 connector labeled “ICE”.  Plug the other end of the cable into 
the JTAG programming connector on the target device. Pin 1 is marked with a triangle on the black 
connector body. An adapter should be used if the signal assignment on the target device is not per Table 3 
or if a different connector type is used on the target device. 

Table 2: ICE Connector to JTAG Cable (2x5) 

Pin Number Signal Function 

1 ICE_E Enables the programming interface when high 

2 GND Ground, return 

3 E_RST Emulator reset 

4 VCC Supply power (+3.3VDC at 300mA, max) 

5 E_TCLK Emulator clock 

6 TMUX Optional signal. Not required for programming 

7 N/C Not connected 

8 N/C Not connected. (+5VDC for TFP3L-MAXQ30) 

9 E_RXTX Emulator data (RX and TX), bidirectional 

10 GND Ground, return 

 

Note: If pin 4 in Table 2 is used to power the target, then a 1000µF/10V capacitor should be placed in 
between VCC and GND of the target board in order to prevent the TFP3 device from resetting due to the 
inrush current. 

 

 

To ZON Device 
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3.3.2 TFP3 Connected to 71M65xx Device (TFP3-8051) 
Plug the multi-colored flat-ribbon cable into the 2x5 connector labeled “ICE”.  Plug the other end of the 
cable (7x1 connector) into the programming connector on the target device. Pin 1 is marked with a 
triangle on the black connector body. An adapter should be used if the signal assignment on the target 
device is not per Table 3 or if a different connector type is used on the target device. 

Table 3: ICE Connector to ICE Cable (7x1) 

Pin Number Signal Function 

1 TMUX Optional signal 

2 ICE_E Enables the programming interface when high 

3 GND – RETURN Ground, return 

4 E_RST Emulator reset 

5 E_TCLK Emulator clock 

6 E_RXTX Emulator data (RX and TX), bidirectional 

7 VCC Supply power (+3.3VDC) 

 

Note: Even though the TFP3 can supply power to the target, many target boards (e.g. 71M653x, 71M652x) 
assign V3P3D to the pin corresponding to pin 7 in Table 3. This means that the target boards still need to 
be powered with a separate DC supply. If pin 7 is used to power the target, then a 1000µF/10V capacitor 
should be placed in between VCC and GND of the target board in order to prevent the TFP3 device from 
resetting due to the inrush current. 

 

To 8051 Device 
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3.4 Device Operation (TFP3Q-MAXQ30, TFP3-8051) 

3.4.1 TFP3 Device Initialization 
This section covers the initialization of the TFP3-8051 and TFP3Q-MAXQ30. The settings of the TFP3 are 
automatically stored, so no further operation is necessary after initialization.   

The following steps are necessary to initialize and load the target code onto the TFP3.  

1. Open the TFP3 GUI on the PC by clicking on Start > All Programs > Maxim Integrated > TFP3 
> TFP3GUI.exe. 

2. Select the Model type and DUT (target) flash size from the drop-down menus. 

 

Figure 5: Selecting the TFP3 Model and Target Flash Size 

3. Normally, the TFP3 GUI auto-detects and connects to the TFP3 device. To manually connect 
to the TFP3, it is necessary to perform the following steps: 

a. On the Options menu, select Configure Serial Port.  

b. On the Device menu, select Connect To TFP3 Device.  

 

Figure 6: Connecting to the TFP3 Device Manually 



Chapter 3:  Setup and Operations The Flash Programmer Model TFP3 

Page 12 Maxim Integrated   Rev.2.3, March 2015 

c. On the File menu, select TFP3 Configuration Commands > Set TFP3 Model Type. 

 

Figure 7: Setting TFP3 Model Type Manually 

d. On the File menu, select TFP3 Configuration Commands > Set DUT Flash Size. 

 

Figure 8: Setting TFP3 DUT Flash Size Manually 

4. (Optional) Select DUT Serial Number Count 

This step sets the unique serial number of the DUT connected to TFP3. This command is 
required to be sent to the TFP3 device only if the parameter preservation feature is required 
by the user. 

On the File menu, select TFP3 Configuration Commands > Set DUT Serial Number Count 

 

Figure 9: Setting TFP3 DUT Serial Number Count 
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5. (TFP3Q-MAXQ30 Model only) Select JTAG Clock Rate 

Set the JTAG clock by selecting File >  TFP3 Configuration Commands > Set TFP3 JTAG Clock. 

 

Figure 10: Setting TFP3 JTAG Clock Rate 

3.4.2 Encryption and Package File Generation (TFP3Q-MAXQ30, TFP3-8051) 
The encryption of the program/target file ensures that its content is secured and not accessible to anyone 
without the key.  AES encryption is used with a key size of 128 bits. Since AES implements a symmetrical 
encryption method, the same key is used for both encryption and decryption. 

Note that the content encryption is only needed for the TFP3Q-MAXQ30 and TFP3-8051, which feature 
the security function.  Once a programming package is loaded on the TFP3, the content is locked.  A new 
programming package file can be uploaded only if it contains an AES key matching the one previously 
loaded or if the TFP3 has been initialized by a factory reset. 

3.4.2.1 AES Key Generation 
The AES key generation is needed in case the previous AES key is not trusted. 

Once the TFP3 is successfully connected to the Loader, select File > TFP3 Configuration Commands > 
Generate TFP3 AES Keys. 

 

Figure 11: Generate TFP3 AES Keys 

Specify the name of the new AES key file. 
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3.4.2.2 AES Key Modification 
This step is needed to allow the newly generated programming package to be loaded in aTFP3 device.  In 
order to do so, the AES key used in the previously loaded programming package (the “old” key) must be 
entered. The steps necessary to do this are indicated below. Alternatively, a new programming package 
(with a new AES key), can be loaded after performing a factory reset on the TFP3. 

After a factory reset, the default key is 0xFFFF.FFFF.FFFF.FFFF.FFFF.FFFF.FFFF.FFFF. 

On the File menu, select TFP3 Configuration Commands > Modify TFP3 AES Keys. 

 

Figure 12: Modify TFP3 AES Key 

Note: Follow the instructions on GUI console for completion of the command. 

The old AES key file would contain the key used for the package file already loaded in the TFP3.  This will 
allow performing operations on a previously loaded TFP3 device.  

A default key is available with the GUI installation package: AES_Keys_old.pas 

3.4.2.3 Create Package File 
The package file is a text file containing the encrypted target image. Create the package file by selecting 
File > TFP3 Programming commands > Generate TFP3 Package file. 

 

Figure 13: Create Package File 

Note: Follow the instructions on the GUI console for completion of the command. 
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3.4.3 Loading the Package File (TFP3Q-MAXQ30, TFP3-8051) 
Load the newly generated package file onto the TFP3 device by selecting File > TFP3 Programming 
Commands > Load TFP3 Package File. 

 

Figure 14: Loading the Package File 

3.4.4 Summary 
Figure 15 summarizes the encryption process. 

 

Figure 15: Encryption Process 
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3.5 Device Operation (TFP3L-MAXQ30) 
The following steps are necessary to initialize and load DUT code into the TFP3L device. The settings of the 
TFP3 programmers are automatically stored, so no further operation is necessary. 

1. Open "TFP3GUI.exe" in your PC from Start > All Programs > Maxim Integrated  > TFP3 > 
TFP3GUI.exe. 

2. Select TFP3 Model and DUT Flash Size 

a. Select Model type and DUT flash size from the drop-down menus. 

 

Figure 16: Selecting the TFP3 Model and DUT Flash Size 

3. Configure and Connect the Serial Port 

Normally, the TFP3 GUI auto-detects and connects to the TFP3 device. To manually connect 
to the TFP3, it is necessary to perform the following steps: 

a. On the Options menu, select Configure Serial Port. (optional) 

b. On the Device menu, select Connect To TFP3 Device.  (optional) 

 

Figure 17: Configuring and Connecting the Serial Port 
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4. Set TFP3 Model Type 

On the File menu, select TFP3 Configuration Commands > Set TFP3 Model Type. 

 

Figure 18: Setting the TFP3 Model Type 

5. Set DUT Flash Size 

On the File menu, select TFP3 Configuration Commands > Set DUT Flash Size. 

 

Figure 19: Setting the DUT Flash Size 

6. (for TFP3L-MAXQ30 Model only) Set JTAG Clock 

Set the JTAG clock by selecting File > TFP3 Configuration Commands > Set TFP3 JTAG Clock. 

 

Figure 20: Setting the TFP3 JTAG Clock 
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7. Load DUT HexFile onto the TFP3  

Note: There is no package file for this model type. 

Load the DUT Hex file onto the TFP3 device by selecting File > TFP3 Programming commands 
> Load DUT Hex File. 

 

Figure 21: Loading the DUT Hex File 

3.6 Target Programming 
The target device can be programmed and verified by one of the following methods: 

● Stand-alone mode: No PC is connected to the TFP3. The programming operation is started by pressing 
the red pushbutton. 

● Host mode: The TFP3 is connected to both the target and to the PC. The programming operation is 
started using the GUI.  

3.6.1 Stand-Alone/Pushbutton Mode 
Connect the target DUT to the TFP3 device using the target cable. Connect the TFP3 to a 5V USB adaptor. 
Wait until the TFP3 status LED turns green. Then press the red pushbutton on the TFP3 device for at least 
0.3 seconds, and then release it. This will initiate the program and verify operation. 

 

Figure 22: Stand-Alone/Push Button Mode 
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Note: In order for the TFP3  to operate properly in Stand-Alone mode, the USB cable should be 
disconnected from the Host PC GUI.  

3.6.2 Host Mode 
Connect the target DUT to the TFP3 device using the target cable. Connect the TFP3 device to the PC with 
the USB cable. Wait until the TFP3 status LED turns green, and then open the TFP3 GUI. Send the program 
and verify DUT command by selecting File > TFP3 Programming Commands > Perform DUT Program And 
Verify. 

 

Figure 23: Program and Verify DUT Command 

Note: Refer to the TFP3 GUI Help documentation for detailed information about the TFP3 GUI 
commands. 
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